Getting Started with BookCAT 98





Introduction





What is BookCAT?





BookCAT is a powerful 32-bit Windows application designed to catalog and manage a personal, club, school, church, or business library. BookCAT will help you know what you have, where it is (including books lent out) and the total value of your collection. 





Technical information





Development tool





BookCAT is developed with Borland Delphi.





To run BookCAT you need





486-based PC or better


Microsoft Windows 95/98, or Windows NT 3.51 or later


16 MB memory (32 MB is recommended)


10 MB free hard disk space





BookCAT needs the following files to run





In the BookCAT 98 folder (usually C:\Program Files\BookCAT32):





BookCAT32.exe


BookCAT32.hlp


BookCAT32.cnt


BookCAT32.lan





In the Windows\System folder:





Msjint32.dll


Msjt3032.dll


Msjter32.dll


Msrd2x32.dll


Msvcrt20.dll


Vbajet32.dll


Vbar2232.dll


Ven2232.olb





In the Program Files\Common Files\Microsoft Shared\DAO folder:





Dao3032.dll





Support





Technical support is available by e-mail or regular mail. Although we answer all questions, we give priority to registered users. Before you contact us, check out the help file first.





When reporting problems, the more information you can provide the better our response can be. If possible, include the following:





What version of BookCAT are you running? You can determine this by choosing About from the BookCAT Help menu. Include the entire "version line"; for example 4.00.02.


What version of Microsoft Windows are you running? For example, Windows 95, Windows 98 or Windows NT.


Is the problem reproducible? If so, how?


If you see a dialog box with an error message when the problem occurs, if possible include the full text of the dialog box, the text in the title bar and the error number. 





Contacting FNProgramvare





All questions, bug reports and suggestions are welcome and should be directed to:





	FNProgramvare


	Pb 721  Krapfoss


	N-1509  Moss


	Norway





	Internet e-mail: info@fnprg.com


	World Wide Web: http://www.fnprg.com





The BookCAT database





All information in BookCAT is stored in a database. A database is simply a file on your hard disk, with the extension .MDB, that contains all the information you have entered into the database.





A database consists of several tables. Each table contains related information. For example, there is one table with information about each book, one with information about each person, one with information about each publisher and so on. Each table contains a various number of fields. For example, the Person table has a field for the name of the person, one field for the date of birth, one field for comments and so on.





BookCAT lets you change the name of all tables and all fields. You can specify a default value for most fields. For example, if most of the books you want to register are purchased this year, you can specify 1999 as the default value for Date Acquired. You can hide the fields you don't want to use. They will then disappear from all windows, menus, lists etc. You only use the fields you want. 





BookCAT lets you work with an unlimited number of databases. This means that you can split your collection into different catalogs and organize it to meet your needs. You can later merge existing databases.





BookCAT uses a relational database model. This means that you register most information only once. For example, you only need to type the name of an author the first time you add a book by this author. Later, you simply choose the name from a list. BookCAT then automatically creates a link between the book and the author. When you modify an entry in a lookup table, for example, to fix a typing error, the change will be reflected in all fields that are linked to the lookup table.





The use of lookup tables to store information has two significant advantages: it saves time and conserves valuable disk space on your computer. It also makes it easier to search for exactly the information you are looking for, or create a group based report. And finally, it allows you to store useful information about each entry in a lookup table. For example, you can store a person's e-mail address or a publisher's Internet home page URL.





Before you can start using BookCAT, you must open a database. You can either open an existing database (for example the SAMPLE.MDB database) or create your own database.





To create a database





1.	Choose New Database from the File menu.


	You see the Create New Database - Specify File Name dialog box.


2.	Select the drive and directory where you want to create the database. In general, we recommend that you create the database in the BookCAT32\Data folder. This folder is selected by default, unless the open database is located in another folder.


3.	In the File name text box, type the name of the database. The name should be one that easily reminds you of the information in the database, for example My Book Collection or Book Library. The file extension identifying the database, .MDB, is added automatically.


4.	Choose Save.


	You see the Create New Database dialog box.


5.	Choose "field level", that tells BookCAT what data fields to make available for you. 


	Click the Wizard button to bring up the Field Wizard that helps you choose the fields you want to use.


	Click the Copy from button to use field definitions from another database.


	Note! You can later change the fields you want to use by choosing Field Definitions from the Tools menu.


6.	Choose OK.


	BookCAT creates the database and opens it. The file name of the database, including drive and folder, is displayed on the title bar of the main BookCAT window. You can now begin adding information.





Notes


·	If you want to organize your collection using only one database, then you do not have to think about databases again. BookCAT will always open this database when you start the application. If, however, you choose to organize your collection in a way that requires several databases, follow the steps above to create as many as you need. To switch from one database to another, see To open a database.





To open a database





1.	From the File menu, choose Open Database.


	You see the Open Database dialog box.


2.	Select the drive and folder where the database is located.


3.	From the list, select the database you want to open.


4.	Press the Open button or double click on the database name.





Notes


·	If you do not exit the program by choosing Exit from the File menu, for example if a system error occurs or there is a power-failure, you may get an error message the next time you try to open the database. If this happens, choose Repair Database from the Tools menu to repair the database.





To compact a database





As you change data in a database, the database file can become fragmented and use more disk space than necessary. Periodically, you can compact your database to defragment the database file. The compacted database is usually smaller.





1.	Choose Compact Database from the File menu.


	You see the Compact Database dialog box.


2.	Choose OK.





Notes


·	Because BookCAT creates a temporary copy of the database during the compact process, you must have enough disk space for both the original and the duplicate database. The compact operation fails if there isn't enough disk space available.





To repair a corrupted database





If you get an error message when you try to open a database, try to use the Repair command to repair the database. The BookCAT database can become corrupted if the program is terminated while it is attempting to write to the database. This can happen when there is a power-failure or a computer hardware problem. 





1.	Choose Repair Database from the Tools menu.


	You see the Repair Database dialog box.


2.	Select the drive and folder where the database is located.


3.	From the list, select the database you want to repair.


4.	Press the Open button or double click on the database name to repair the database.





Notes


·	Because BookCAT creates a temporary copy of the database during the repair process, you must have enough disk space for both the original and the duplicate database. The repair operation fails if there isn't enough disk space available.





Data Entry





BookCAT stores four basic types of information: 





·	Book information, such as author, title, publish date, publisher, ISBN, etc. “Book” is a general term that can mean a book, newspaper, magazine, etc. 


·	Contents information (sections), such as author, title, page from, page to, keywords, etc. (sections) is a general term for any work (chapters, short stories, individual essays, etc) contained within the book (a book can contain multiple sections). It's up to you whether you want to register contents information or not. For most books you will probably not want to do this, but this feature can be extremely useful in certain situations (for example if the book contains multiple short stories by various authors).


·	Lookup information, that you add once and then reuse later. The Person lookup table is a good example. Information about the person (author, editor or translator), for example name, country of origin, is added to the Person table the first time you register a book written by this author. Later, you simply choose the name from a list. When you modify an entry in a lookup table, for example to fix a typing error, the change will be reflected in all fields that are linked to this lookup table.


·	Loan information, books that currently are, or have been, "on loan". 





To add a new book





1.	Choose New from the Book menu or click the New button on the toolbar.


	BookCAT activates the Book window. You are now ready to begin adding information.


	Notice how the first section of the status bar displays New. This indicates that a new book is added, but it has not yet been saved.


2.	Specify the relevant information in the Book window.


3.	If you want to register the contents of the book, click the New button in the Contents window. It's up to you whether you want to register contents information or not. For most books you will probably not want to do this, but this feature can be extremely useful in certain situations (for example if the book contains multiple short stories by various authors).





Notes


·	If you are unsure of what information you are supposed to specify in a field, press the Help button on the toolbar and then click on the field.


·	You do not need to manually save the book, BookCAT will automatically save any changes when you choose one of the menu options.





To edit a book





1.	From the list of books in the Browse window, locate the book you want to edit.


2.	To activate the Book window, double click on the book in the Browse window or choose Book from the Window menu.


3.	Modify the information as necessary in the Book window.





Notes


·	You do not need to manually save the changes, BookCAT will automatically save any changes when you choose one of the menu options.





To delete books





1.	From the list of books in the Browse window, select the book you want to delete.


2.	Choose Delete / Current Book from the Book menu.


	Notice the word Deleted on the status bar. This informs you that the book is marked as deleted. It has not yet been removed from the database.


3.	Repeat steps 1 - 2 for all books you want to delete.


4.	From the File menu, choose Compact Database.


	You see the Compact Database dialog box.


5.	Select the Remove deleted books check box.


6.	Click the OK button.


7.	BookCAT asks you to confirm that you want to remove the deleted book(s).


	Click the OK button.





To add a new section





1.	Activate the Contents window by choosing Contents from the Window menu.


2.	Click the New button in the Contents window.


3.	If the Use contents template option is activated in the Preferences dialog box, you see the Contents Template dialog box. Here you can specify information that is relevant to all sections (or most of the sections) in the book. This template is used when you add new sections to the book.


	Note! If the book only contains one section, there is no need to use a template.


	To use the template, click the Use button on the toolbar or choose Use from the Template menu. 


	BookCAT adds a new section to the book.


4.	Specify the relevant information in the Contents Edit window.


5.	If the book contains more than one section, choose New from the Contents menu or click the New button on the toolbar to add the next section.





Notes


·	It's up to you whether you want to register contents information or not. For most books you will probably not want to do this, but this feature can be extremely useful in certain situations (for example if the book contains multiple short stories by various authors).


·	You do not need to manually save the section, BookCAT will automatically save any changes when you choose one of the menu options or close the window.





To edit a section





1.	From the list of books in the Browse window, locate the book that contains the section you want to edit.


2.	Activate the Contents window by choosing Contents from the Window menu.


3.	From the list of sections, select the section you want to edit.


4.	Click the Edit button.


5.	Modify the information as necessary in the Contents Edit window.





Notes


·	You do not need to manually save the section, BookCAT will automatically save any changes when you choose one of the menu options or close the window.





To delete a section





1.	From the list of books in the Browse window, locate the book that contains the section you want to delete.


2.	Activate the Contents window by choosing Contents from the Window menu.


3.	From the list of sections, select the section you want to delete.


4.	Click the Delete button.


	BookCAT asks you to confirm that you really want to delete the section. 


	Press the Yes button.


	BookCAT deletes the section, and updates the index number for the rest of the sections in the book.





Notes


·	You cannot delete sections from the Contents Edit or the Contents View windows.


·	Unlike books, sections are deleted immediately.





To add a new lookup entry





1.	Choose Edit Table from the Lookup menu.


	You see the Choose Lookup Table dialog box.


2.	Select the lookup table you want to add a new entry to.


3.	Click the OK button.


	You see the Lookup "Table Name" dialog box.


4.	Click the + button.


	BookCAT activates the Details tab.


5.	Fill in as much information as you want.





Notes


·	You do not need to manually save the entry, BookCAT will automatically save any changes when you move to another entry or close the dialog box.





To edit a lookup entry





1.	Choose Edit Table from the Lookup menu.


	You see the Choose Lookup Table dialog box.


2.	Select the lookup table you want to edit.


3.	Click the OK button.


	You see the Lookup "Table Name" dialog box.


4.	Locate the item you want to edit from the list.


	You can use the text box above the list to quickly locate the desired entry. As you type, BookCAT tries to locate a matching item in the list.


5.	Click the Details tab.


6.	Modify the information as necessary.





Notes


·	You do not need to manually save the entry, BookCAT will automatically save any changes when you move to another entry or close the dialog box.





To delete a lookup entry





1.	Choose Edit Table from the Lookup menu.


	You see the Choose Lookup Table dialog box.


2.	Select the lookup table in which you want to delete an entry.


3.	Click the OK button.


	You see the Lookup "Table Name" dialog box.


4.	Locate the item you want to delete from the list.


	You can use the text box above the list to quickly locate the desired entry. As you type, BookCAT tries to locate a matching item in the list.


5.	Click the - button to delete the selected entry.


	BookCAT asks you to confirm that you really want to delete it. 


	Press the Yes button.





Viewing Information





To mark books





BookCAT allows you to mark books. Marking and unmarking books can be extremely useful if you want to select different books based on specific criteria (for example, all books written by a specific author) for a pending action. You may view, edit, search among, or even print only the books that have been marked.





The checkmark button (looks like a "V") on the toolbar indicates whether the current book is marked or not. If the button is "in" (pressed), the book is marked. If it is “out” (released), the book is not marked. You can mark or unmark all books by using the mark commands on the Book menu.





1.	To mark or unmark the current book, choose Mark / Current Book from the Book menu, or simply click the Mark button on the toolbar. You can also press Ctrl+M.


	This command toggles between the two modes. If the book was unmarked, it is marked. If the book was marked, it is unmarked.


2.	To mark all books, choose Mark / Mark All from the Book menu.


3.	To unmark all books, choose Mark / Unmark All from the Book menu.


4.	To invert the marking, choose Mark / Invert Marking from the Book menu.


	Marked books become unmarked, and unmarked books become marked.





To view the book subset





By default, BookCAT displays all books in your database. If you want to view only the books that are marked, the subset, use the Subset command on the View menu. This is very useful when you want to look at just some of the books (for example all books written by a specific author). 





1.	Choose Subset from the View menu, or click the Subset button on the toolbar. You can also press F9.


	This command toggles between the two modes. If the subset was active, it is deactivated. If the subset was not active, it is activated.





To use the contents view





When you add a new book or look at existing books, BookCAT displays the sections in the same order as they appear in the book (in the Contents window). Occasionally you may want to look at sections without regard to the book in which they are located.





1.	Choose Contents View from the Contents menu or click the Contents View button on the toolbar.


	If some of the sections are marked, BookCAT asks if you want to view only the marked sections.


	You see the Contents View window. 


2.	You can now browse the sections the same way you browse the books. 





Notes


·	To edit the active section, choose Edit from the Contents menu or double click the section.


·	It is not possible to add new sections or delete existing sections from the Contents View window.





Searching and Querying





You can effectively search the database for information that you require. Search in all fields with any combination of fields and operators. In addition, BookCAT lets you cross reference up to five fields. This is an extremely flexible way to search and query data.





There are six different ways to search and query data:


1.	Quick search. This is the easiest way to search. Simply fill in the fields you want to search in, choose OK, and BookCAT handles the rest!


2.	Simple search. Lets you define a search criteria based on up to two fields. You specify field, operator and the value you want to search for. The search criteria can be saved to a file for later use.


3.	Advanced search. Lets you define a search criteria that can contain an unlimited number of fields. You can group the fields in different ways using parenthesis and the logical operators AND/OR. The search criteria can be saved to a file for later use.


4.	Summary search. Specify the field you want to search in from the drop-down list. All unique values are then displayed in a list box. Select the value you want to search for and choose OK. The number of occurrences of each value is also displayed. This might be very useful for statistic purposes.


5.	Global Search. Lets you search in all fields.


6.	Cross references (X-Ref). The Cross Reference module lets you cross reference up to five fields. This is an extremely flexible way to search and query data.





If you want to replace the field value for more than one book or section in one operation, use the search and replace command (choose Replace from the Edit-menu).


Before you execute a search, you must specify the following options:





Search subset


Select the Search subset option if you only want to search the subset (that is, only marked books or sections).





Show all


Select the Show all option if you want BookCAT to mark all entries (books or sections) that are found during the search and then show all these entries. If not, BookCAT only shows the first entry that was found. You have to choose Show Next from the Search menu to show the next entry.





Show books


When searching for sections, select the Show books option if you want the books the sections are located in as the search result.





Working with Reports





BookCAT includes a report designer that lets you create almost any type of report. Use one of the more than 80 pre-defined reports, or create your own reports from scratch. You have full control over data fields, groups, sort order, columns, fonts, colors, paper size, margins and print orientation. You can add the reports you use the most to the Report menu. 





During the installation of BookCAT, the setup program copied the pre-defined reports to the following folders under the BookCAT folder:





\Reports\Book		Book reports 


\Reports\Contents	Contents reports 


\Reports\LoanTrans	Loan transaction reports 


\Reports\Lookup	Lookup reports 





All these reports are automatically added to the Report menu the first time BookCAT is run.


To work with the Report Designer, choose Report Designer from the Report menu or click the 


Report Designer button on the toolbar. 





To modify the contents of the Report menu, choose Edit Menu from the Report menu or click the Edit Report Menu button on the toolbar.





About the Report Designer





You use the Report Designer to create a new report or modify an existing report. To activate the Report Designer, choose Report Designer from the Report menu or click the Report Designer button on the toolbar.





Reports are made up of bands. The way data appears in a report is determined by the kind of band a data field is in. For example, if a field is in the Detail band, the field data from every record appears in the report. If a field is in the Column Header band, the field data is only printed at the top of each column. If a field is in the Page Footer band, the field data is only printed at the bottom of each page.





The Report Designer makes extensive use of popup menus to allow you to quickly set report object properties. To display a popup menu, click with the right mouse button on a band or an object. You specify the text formatting (font, font size, color etc.) from the Format toolbar. The text formatting affects all selected objects.





To create a new report





1.	Choose New from the File menu or click the New button on the toolbar.


	You see the Create New Report dialog box.


2.	Select the type of report you want to create:


	Book report - A book report prints information from the Book table. If you want, you can also include all sections in the book in the order they appear in the book (on the Sub-Detail band).


	Contents report - A contents report prints information from the Contents table (a book can contain multiple sections, for example chapters, short stories or individual essays). The sections are printed without regard to the book in which they are located. If you want, you can also include information about the book (for example Reference No or Location).


	Loan Transaction report - A loan transaction report prints information based on the Loan Transaction table, that is, books that are or have been “on loan”. You can include information from the Book table (Title, Author, ISBN etc.), the Loan Transaction table (Date Borrowed, Date Due, Date Returned etc.) and the Borrower table (Name, Address, Phone, Fax etc.).


	Lookup report - A lookup reports prints information from the chosen lookup table. This type of report is very useful when you want an overview of the contents of a lookup table.


3.	Click the OK button.


	BookCAT creates the new report. You can now begin adding fields to the report.





To specify groups





Grouping a report means breaking the data into meaningful groups before it appears in your report. Data grouping is used to create easy-to-read blocks of data. You can create up to five groups in a report.





For each group, there are two corresponding bands: the Group Header and the Group Footer. These two bands will only print each time the value of the group field changes. The Group Header is printed above the Detail band, while the Group Footer is printed below the Detail band.





1.	Choose Groups from the Report menu or click the Groups button on the toolbar.


	You see the Groups dialog box.


2.	From the drop-down list, select the field you want to base the group on.


3.	Modify the group properties, if necessary.


	Note! Context-sensitive help is available if you click on the ? button at the top of the active window, and then click the item you want information about.


4.	Repeat step 2 - 3 for each group you want to add or modify.


	Note! You select the group you want to edit by clicking on the corresponding tab.


5.	Click the OK button to save the changes and close the dialog box.





Notes


·	When you create a new group, BookCAT automatically adds the group field to the Group Header band.





To specify sort order





1.	Choose Sort Order from the Report menu or click the Sort Order button on the toolbar.


	You see the Edit Sort Order dialog box.


2.	From the list on the left, select the fields you want to base the sort order on.


3.	Click the OK button to use the new sort order.





To specify what information to include





You can include all entries in your report, or you can restrict your report to specific entries; either the subset (that is, marked entries) or let the filter specify what entries to include.





1.	To include all entries, choose Include / All from the Report menu or press the Include All button on the toolbar.


	To include only the subset, choose Include / Subset from the Report menu or press the Include Subset button on the toolbar.


	Note! The subset option is only available in book and contents reports.


	To let the filter specify what entries to include, choose Include / Filter from the Report menu or press the Include Filter button on the toolbar.


	Note! The filter option is only available when a filter is already defined.





To specify filter





1.	Choose Filter from the Report menu or click the Filter button on the toolbar.


	You see the Filter dialog box.


	If you are defining a simple filter, continue with step 2. If you are defining an advanced filter, proceed to step 10.


2.	From the drop-down list the cursor is in, select the field you want to base the filter on.


3.	Select the operator from the drop-down list on the right.


4.	Specify the value to use in the filter.


	If you want to combine two fields in the filter, continue with step 5. If not, proceed to step 9.


5.	From the drop-down list in the box below, select the second field you want to base the filter on.


6.	Select the operator from the drop-down list on the right.


7.	Specify the value to use in the filter.


8.	Specify whether you want to combine the two fields with the AND operator or the OR operator by selecting either AND or OR.


9.	To use the filter, choose Use Filter from the Filter menu or click the Use Filter button on the toolbar.


	The simple filter is now defined.


10.	To start defining the advanced filter, choose the Add field button to add a field.


	You see the Add Field dialog box.


11.	From the drop-down list the cursor is in, select the field you want to base the filter on.


12.	Select the operator from the drop-down list on the right.


13.	Specify the value to use in the filter.


14.	Choose the OK button to add this field to the filter criteria.


15.	If you want to add another field to the filter criteria, repeat step 10 - 14.


	Note! If you want to combine two field with the OR operator, click the OR button before you add the next field.


16.	To use the filter, choose Use Filter from the Filter menu or click the Use Filter button on the toolbar.





Notes


·	To specify whether the Filter button on the toolbar should activate the Simple Filter or the Advanced Filter dialog box, click with the right mouse button on the button and choose from the popup menu.





To add a new object





1.	From the toolbar, select the type of object you want to add.


	The following objects are available:


Text Label - The Text Label object simply prints the text you specify. Text labels are typically used for report titles, page headings, column headings, etc.


Data Field - The Data Field object is used to print text from a data field in the database. This is the report object you will use the most.


Calculate - The Calculate object is used to perform common report calculations and print the resulting value. The calculation is performed based on the value of the specified data field.


System - The System object is used to print common report information, such as the current date, time or page number.


Combination


Field - The Combination Field object "combines" the text of two or more objects into one object.


Shape - The Shape object is used to print graphical shapes.


Line - The Line object is used to print vertical or horizontal lines.


Image - Use the Image object to print a graphical image. BookCAT supports BMP, GIF and JPG image formats.


2.	Click on the band you want to add the object to.





To select an object





To do certain things with an object (change the font, move it, etc.), you first have to select it. Select means to point to the object with the mouse and then to click the left mouse button to choose it.





For example, to change font size, you first select the object for which you want to change the font size. Then you specify the font size from the Format toolbar.





To select a single object


1.	Click on the object.


	Sizing handles appear around the object to indicate that it is selected.





Selecting multiple objects


1.	Hold down the Ctrl key and click on the objects you want to select.


	Handles will appear on each selected object. You can then move or delete the objects as a group. You can also change the font or text formatting for all selected objects in one operation.





Notes


·	You cannot resize objects when multiple objects are selected.





To move an object





1.	Select the object(s) you want to move.


2.	Click on the object with the mouse, and drag it to the new position.


	If multiple objects are selected, click on one of the objects and drag.





Notes


·	You can move the selected object(s) one pixel at the time by holding down Ctrl while you use the arrow keys.


·	You cannot drag an object from one band to another band. You have to copy the object to the clipboard and then past it onto the other band.


·	You can set the position of an object by clicking with the right mouse button on the object and choose Position from the popup menu.





To resize an object





1.	Select the object you want to resize. 


2.	Drag the field's surrounding sizing handles to increase or decrease the size of the object.





Notes


·	You can resize the object one pixel at the time by holding down Shift while you use the arrow keys.


·	You cannot resize objects when multiple objects are selected.


·	You can set the size of an object by clicking with the right mouse button on the object and choose Position from the popup menu.





To modify object properties





1.	Click on the object with the right mouse button.


2.	Choose the desired property from the popup menu.





To print a report





1.	Click the Print button on the toolbar or choose Print from the File menu.


	You see the Print dialog box. Click OK to print the report.





Notes


·	If you just want to check the report layout, hold down Ctrl while you choose the print command, and BookCAT will only print the first page of the report only.





To preview a report





1.	Click the Print Preview button on the toolbar or choose Print Preview from the File menu.


	You see the Print Preview dialog box.


2.	Use the navigator buttons to move to another page.


3.	Use the Whole Page, Page Width or 100% buttons to alter the zoom level. You can also specify the zoom level in the Zoom text box and then press Enter to activate the new zoom level.


4.	Click the Print button to send to report to the printer.





Notes


·	If you just want to check the report layout, hold down Ctrl while you choose the print command, and BookCAT will only preview the first page of the report.


